<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">

<head>
  <meta charset="UTF-8">
  <meta name="viewport" content="initial-scale=1.0, width=device-width, height=device-height, minimum-scale=1.0, maximum-scale=1.0, user-scalable=no" />
  <link rel="profile" href="http://gmpg.org/xfn/11">
  <link rel="icon" href="http://abcnewspapers.com/wp-content/themes/paperboy/img/favicon.ico" />
  <link rel="pingback" href="http://abcnewspapers.com/xmlrpc.php">
    <style>
  span.ginput_price {visibility: hidden;}  </style>
  <title>
ABC Newspapers |   Blaine seeks high-end grocery store  </title>
  <script src='http://abcnewspapers.com/wp-content/themes/paperboy/js/modernizr.min.js'></script>

  <!-- NoIndex Switch -->
    <!-- Always force latest IE rendering engine (even in intranet) & Chrome Frame -->
  <!--[if IE]><meta http-equiv="cleartype" content="on"><![endif]-->
  <!--[if IE]><meta http-equiv='X-UA-Compatible' content='IE=edge,chrome=1'><![endif]-->
  <script type="text/javascript" async="async" src="http://widgets.outbrain.com/outbrain.js"></script>
  
  <!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','//connect.facebook.net/en_US/fbevents.js');

fbq('init', '471395746339667');
fbq('track', 'PageView');</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=471395746339667&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->  <title>Blaine seeks high-end grocery store &#8211; ABC Newspapers</title>

	  <link rel='dns-prefetch' href='//abcnewspapers.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="ABC Newspapers &raquo; Feed" href="http://abcnewspapers.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="ABC Newspapers &raquo; Comments Feed" href="http://abcnewspapers.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="ABC Newspapers &raquo; iCal Feed" href="http://abcnewspapers.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="ABC Newspapers &raquo; Blaine seeks high-end grocery store Comments Feed" href="http://abcnewspapers.com/2017/05/18/blaine-seeks-high-end-grocery-store/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/abcnewspapers.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=78ceedbb703a626b7e40922992d75818"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='validate-engine-css-css'  href='http://abcnewspapers.com/wp-content/plugins/wysija-newsletters/css/validationEngine.jquery.css?ver=2.7.7' type='text/css' media='all' />
<link rel='stylesheet' id='awesome-weather-css'  href='http://abcnewspapers.com/wp-content/plugins/awesome-weather-pro/awesome-weather.css?ver=78ceedbb703a626b7e40922992d75818' type='text/css' media='all' />
<style id='awesome-weather-inline-css' type='text/css'>
.awesome-weather-wrap { font-family: 'Open Sans', sans-serif;  font-weight: 400; font-size: 14px; line-height: 14px; } 
</style>
<link rel='stylesheet' id='opensans-googlefont-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A400%2C300&#038;ver=78ceedbb703a626b7e40922992d75818' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='http://abcnewspapers.com/wp-includes/css/dashicons.min.css?ver=78ceedbb703a626b7e40922992d75818' type='text/css' media='all' />
<link rel='stylesheet' id='symple_shortcode_styles-css'  href='http://abcnewspapers.com/wp-content/plugins/symple-shortcodes/includes/css/symple_shortcodes_styles.css?ver=78ceedbb703a626b7e40922992d75818' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-full-calendar-style-css'  href='http://abcnewspapers.com/wp-content/plugins/the-events-calendar/src/resources/css/tribe-events-full.min.css?ver=4.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-calendar-style-css'  href='http://abcnewspapers.com/wp-content/plugins/the-events-calendar/src/resources/css/tribe-events-theme.min.css?ver=4.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-calendar-full-mobile-style-css'  href='http://abcnewspapers.com/wp-content/plugins/the-events-calendar/src/resources/css/tribe-events-full-mobile.min.css?ver=4.3.2' type='text/css' media='only screen and (max-width: 768px)' />
<link rel='stylesheet' id='tribe-events-calendar-mobile-style-css'  href='http://abcnewspapers.com/wp-content/plugins/the-events-calendar/src/resources/css/tribe-events-theme-mobile.min.css?ver=4.3.2' type='text/css' media='only screen and (max-width: 768px)' />
<link rel='stylesheet' id='column-styles-css'  href='http://abcnewspapers.com/wp-content/plugins/wens-responsive-column-layout-shortcodes/assets/css/style.css?ver=78ceedbb703a626b7e40922992d75818' type='text/css' media='all' />
<link rel='stylesheet' id='wp-lightbox-2.min.css-css'  href='http://abcnewspapers.com/wp-content/plugins/wp-lightbox-2/styles/lightbox.min.css?ver=1.3.4' type='text/css' media='all' />
<link rel='stylesheet' id='paperboy-mainstyle-css'  href='http://abcnewspapers.com/wp-content/themes/paperboy/scss/main.min.css?ver=78ceedbb703a626b7e40922992d75818' type='text/css' media='all' />
<link rel='stylesheet' id='paperboy-slick-style-css'  href='http://abcnewspapers.com/wp-content/themes/paperboy/js/slick/slick.css?ver=78ceedbb703a626b7e40922992d75818' type='text/css' media='all' />
<link rel='stylesheet' id='paperboy-slick-theme-css'  href='http://abcnewspapers.com/wp-content/themes/paperboy/js/slick/slick-theme.css?ver=78ceedbb703a626b7e40922992d75818' type='text/css' media='all' />
<link rel='stylesheet' id='recently-css'  href='http://abcnewspapers.com/wp-content/plugins/recently/style/recently.css?ver=1.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-lazyloadxt-fadein-css-css'  href='//abcnewspapers.com/wp-content/plugins/a3-lazy-load/assets/css/jquery.lazyloadxt.fadein.css?ver=78ceedbb703a626b7e40922992d75818' type='text/css' media='all' />
<link rel='stylesheet' id='a3a3_lazy_load-css'  href='//abcnewspapers.com/wp-content/uploads/sites/19/sass/a3_lazy_load.min.css?ver=1478291344' type='text/css' media='all' />
<script type='text/javascript' src='//cdn.broadstreetads.com/init.js?ver=78ceedbb703a626b7e40922992d75818'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tribe_events_linked_posts = {"post_types":{"tribe_venue":"venue","tribe_organizer":"organizer"}};
/* ]]> */
</script>
<script type='text/javascript' src='http://abcnewspapers.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://abcnewspapers.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='//fast.wistia.com/static/E-v1.js?ver=78ceedbb703a626b7e40922992d75818'></script>
<script type='text/javascript' src='http://abcnewspapers.com/wp-content/plugins/daniel_wegner-my-video-ads-9bb99117cec6/js/wistia-embed-preroll.js?ver=1.1'></script>
<link rel='https://api.w.org/' href='http://abcnewspapers.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://abcnewspapers.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://abcnewspapers.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Grand opening set for renovated Sand Creek Park' href='http://abcnewspapers.com/2017/05/18/grand-opening-set-for-renovated-sand-creek-park/' />
<link rel="canonical" href="http://abcnewspapers.com/2017/05/18/blaine-seeks-high-end-grocery-store/" />
<link rel='shortlink' href='http://abcnewspapers.com/?p=202684' />
<link rel="alternate" type="application/json+oembed" href="http://abcnewspapers.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fabcnewspapers.com%2F2017%2F05%2F18%2Fblaine-seeks-high-end-grocery-store%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://abcnewspapers.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fabcnewspapers.com%2F2017%2F05%2F18%2Fblaine-seeks-high-end-grocery-store%2F&#038;format=xml" />

<!-- WordPress Facebook Open Graph protocol plugin (WPFBOGP v2.0.13) http://rynoweb.com/wordpress-plugins/ -->
<meta property="fb:app_id" content="117651516683"/>
<meta property="og:url" content="http://ecmpublishers.com/2017/05/18/blaine-seeks-high-end-grocery-store/"/>
<meta property="og:title" content="Blaine seeks high-end grocery store"/>
<meta property="og:site_name" content="ABC Newspapers"/>
<meta property="og:description" content="The city of Blaine knows there’s demand from residents for more grocery store options in Blaine.  One of the big tasks for Blaine Economic Development Coord"/>
<meta property="og:type" content="article"/>
<!-- There is not an image here as you haven't set a default image in the plugin settings! -->
<meta property="og:locale" content="en_us"/>
<!-- // end wpfbogp -->
  
    <script>
    var _gaq=[['_setAccount','UA-5290950-16'],['_trackPageview']];
    (function(d,t){var g=d.createElement(t),s=d.getElementsByTagName(t)[0];
      g.src=('https:'==location.protocol?'//ssl':'//www')+'.google-analytics.com/ga.js';
      s.parentNode.insertBefore(g,s)}(document,'script'));
      </script>  
      <script>
      var ad_slots = {billboard:43523, mobile:43524};
      </script>
</head>

<body class="post-template-default single single-post postid-202684 single-format-standard">
  <div id="page" class="hfeed site">
    <nav id="offcanvas" class="offcanvas" role="navigation">
      <form class="top-search-form" action="/">
    <input type="text" value="" id="top-search-input" name="s" placeholder="Search">
    <label id="top-search-label" for="top-search-input">Search</label>
</form>      <div id="offcanvas-menu" class="offcanvas-menu"><ul id="menu-main-menu" class="menu"><li id="menu-item-162724" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-162724"><a href="/">Home</a></li>
<li id="menu-item-162725" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-162725"><a href="#">Sections</a>
<ul class="sub-menu depth-0">
	<li id="menu-item-119514" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-119514"><a href="http://abcnewspapers.com/category/public-safety/">Public Safety</a></li>
	<li id="menu-item-71231" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-71231"><a href="http://abcnewspapers.com/category/sports/">Sports</a>
	<ul class="sub-menu depth-1">
		<li id="menu-item-94082" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-94082"><a href="http://abcnewspapers.com/tag/golden-rams/">Golden Rams</a></li>
		<li id="menu-item-94083" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-94083"><a href="http://abcnewspapers.com/category/sports/?tag=andover">Andover</a></li>
		<li id="menu-item-94084" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-94084"><a href="http://abcnewspapers.com/category/sports/?tag=anoka">Anoka</a></li>
		<li id="menu-item-94085" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-94085"><a href="http://abcnewspapers.com/category/sports/?tag=blaine">Blaine</a></li>
		<li id="menu-item-94086" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-94086"><a href="http://abcnewspapers.com/category/sports/?tag=coon-rapids">Coon Rapids</a></li>
		<li id="menu-item-152055" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-152055"><a href="/category/sports/?tag=legacy">Legacy</a></li>
		<li id="menu-item-152056" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-152056"><a href="/category/sports/?tag=pact">PACT</a></li>
		<li id="menu-item-94087" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-94087"><a href="http://abcnewspapers.com/category/sports/?tag=spring-lake-park">Spring Lake Park</a></li>
		<li id="menu-item-94088" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-94088"><a href="http://abcnewspapers.com/category/sports/?tag=st-francis">St. Francis</a></li>
		<li id="menu-item-56746" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56746"><a href="http://abcnewspapers.com/category/sports/?tag=outdoors">Outdoors</a></li>
	</ul>
</li>
	<li id="menu-item-119515" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-119515"><a href="http://abcnewspapers.com/category/government/">Government</a></li>
	<li id="menu-item-56740" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56740"><a href="http://abcnewspapers.com/category/education/">Education</a></li>
	<li id="menu-item-56771" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-56771"><a href="http://abcnewspapers.com/category/arts-entertainment/">Arts &#038; Entertainment</a>
	<ul class="sub-menu depth-1">
		<li id="menu-item-56772" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56772"><a href="http://abcnewspapers.com/category/arts-entertainment/">Entertainment News</a></li>
		<li id="menu-item-56774" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56774"><a href="http://abcnewspapers.com/play-sodoku/">Play Sodoku</a></li>
		<li id="menu-item-56773" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56773"><a href="http://abcnewspapers.com/coffee-break-corner/">Coffee Break Corner</a></li>
	</ul>
</li>
	<li id="menu-item-149396" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-149396"><a href="http://abcnewspapers.com/category/lifestyle/">Lifestyle</a></li>
	<li id="menu-item-56749" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56749"><a href="http://abcnewspapers.com/category/community-people/">Community &#038; People</a></li>
	<li id="menu-item-162727" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-162727"><a href="#">Announcements</a>
	<ul class="sub-menu depth-1">
		<li id="menu-item-161924" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-161924"><a href="http://abcnewspapers.com/category/announcements/">View Announcements</a></li>
		<li id="menu-item-132569" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-132569"><a href="https://announcements.ecmpublishers.com/announcements/">Submit Announcement</a></li>
		<li id="menu-item-119753" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-119753"><a href="/tag/obituaries">Obituaries</a></li>
		<li id="menu-item-119902" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-119902"><a href="http://obits.ecmpublishers.com/">Place an Obituary</a></li>
	</ul>
</li>
	<li id="menu-item-56756" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-56756"><a href="http://abcnewspapers.com/category/opinion-columns/">Opinion &#038; Columns</a>
	<ul class="sub-menu depth-1">
		<li id="menu-item-56759" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56759"><a href="/?tag=columns">Columns</a></li>
		<li id="menu-item-56760" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56760"><a href="http://hometownsource.com/blogs">Blogs</a></li>
		<li id="menu-item-56757" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56757"><a href="/?tag=editorials">Editorials</a></li>
		<li id="menu-item-56761" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56761"><a href="/tag/writers-block/">Writers Block</a></li>
		<li id="menu-item-56758" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56758"><a href="/tag/letters-to-the-editor/">Letters</a></li>
		<li id="menu-item-144502" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-144502"><a href="http://abcnewspapers.com/submit-a-letter-to-the-editor/">Submit A Letter To The Editor</a></li>
	</ul>
</li>
	<li id="menu-item-192076" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-192076"><a href="http://abcnewspapers.com/category/faith/">Faith</a></li>
	<li id="menu-item-124176" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-124176"><a href="/category/public-notices/">Public Notices</a></li>
</ul>
</li>
<li id="menu-item-162726" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-162726"><a href="#">Communities</a>
<ul class="sub-menu depth-0">
	<li id="menu-item-162758" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-162758"><a href="http://abcnewspapers.com/andover/">Andover</a></li>
	<li id="menu-item-162762" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-162762"><a href="http://abcnewspapers.com/anoka/">Anoka</a></li>
	<li id="menu-item-162759" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-162759"><a href="http://abcnewspapers.com/anoka-county/">Anoka County</a></li>
	<li id="menu-item-162760" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-162760"><a href="http://abcnewspapers.com/blaine/">Blaine</a></li>
	<li id="menu-item-162761" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-162761"><a href="http://abcnewspapers.com/coon-rapids/">Coon Rapids</a></li>
	<li id="menu-item-162754" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-162754"><a href="http://abcnewspapers.com/northern-anoka-county/">Northern Anoka County</a></li>
	<li id="menu-item-162756" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-162756"><a href="http://abcnewspapers.com/ramsey/">Ramsey</a></li>
	<li id="menu-item-162755" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-162755"><a href="http://abcnewspapers.com/spring-lake-park/">Spring Lake Park</a></li>
</ul>
</li>
<li id="menu-item-163180" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-163180"><a>More</a>
<ul class="sub-menu depth-0">
	<li id="menu-item-120869" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-120869"><a href="http://abcnewspapers.com/subscribe/">Subscribe</a></li>
	<li id="menu-item-56753" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56753"><a href="/tag/looking-back/">Looking Back</a></li>
	<li id="menu-item-83417" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-83417"><a href="http://theadspider.com/browse/awpcp/setregion/276/ABCNewspapers.com">Classifieds</a></li>
	<li id="menu-item-130951" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-130951"><a href="/smart-money">Smart Money</a></li>
	<li id="menu-item-130252" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-130252"><a href="/advertising-information/">Advertising Info</a></li>
</ul>
</li>
</ul></div>              <div class="site-social">
                      <div class="social-icon">
              <a href="https://www.facebook.com/abcnewspapers" title="Facebook">
                <svg class="facebooksvg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="32px" height="32px" viewBox="0 0 32 32" enable-background="new 0 0 32 32" xml:space="preserve"><path d="M0 0v32h32V0H0L0 0z M13.741 24.704V16h-1.796v-3h1.796v-1.801 c0-2.447 1.015-3.902 3.897-3.902h2.4v3h-1.5c-1.122 0-1.197 0.42-1.197 1.202L17.338 13h2.717l-0.317 2.999h-2.399v8.705H13.741 L13.741 24.704z M13.741 24.7"/></svg>              </a>
            </div>
            
                          <a href="https://twitter.com/abcnewspapers" title="Twitter">
                <div class="social-icon">
                  <svg class="twittersvg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="32px" height="32px" viewBox="0 0 32 32" enable-background="new 0 0 32 32" xml:space="preserve"><g><path d="M0 0v32h32V0H0z M23.943 11.324c-0.066 0.112-0.412 0.508-0.781 0.869c-0.626 0.622-0.66 0.689-0.66 1.2 c0 0.803-0.379 2.475-0.76 3.391c-0.703 1.717-2.213 3.49-3.721 4.383c-2.124 1.254-4.952 1.571-7.333 0.8 c-0.793-0.25-2.156-0.883-2.156-0.996c0-0.033 0.414-0.078 0.917-0.09c1.05-0.023 2.1-0.316 2.995-0.836l0.603-0.361l-0.692-0.237 c-0.985-0.339-1.867-1.119-2.09-1.853c-0.066-0.238-0.045-0.248 0.581-0.248l0.647-0.013l-0.547-0.261 c-0.648-0.326-1.24-0.881-1.531-1.445c-0.212-0.408-0.48-1.436-0.402-1.515c0.022-0.033 0.3 0 0.5 0.1 c0.772 0.3 0.9 0.2 0.424-0.261c-0.837-0.858-1.093-2.135-0.691-3.344l0.189-0.543l0.738 0.7 c1.507 1.5 3.3 2.4 5.3 2.621l0.559 0.068l-0.033-0.553c-0.099-1.436 0.783-2.746 2.18-3.255 c0.514-0.18 1.385-0.203 1.955-0.043c0.225 0.1 0.6 0.3 0.9 0.497l0.548 0.373l0.604-0.193 c0.336-0.101 0.783-0.271 0.982-0.383C23.453 9.9 23.6 9.8 23.6 9.877c0 0.192-0.413 0.848-0.761 1.2 c-0.469 0.509-0.334 0.6 0.6 0.215C24.045 11.1 24.1 11.1 23.9 11.324z" /></g></svg>                </a>
              </div>
                          </div>
                      </nav>
          <!--END: offcanvas -->
          <div id="canvas">
            <nav class="links-menu-wrapper" role="navigation">
	<span class="links-menu-intro"></span> 
	<div class="links-menu"><ul id="menu-links-menu" class="menu"><li id="menu-item-162323" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-162323"><a href="http://abcnewspapers.com/advertising-information/">Advertising Information</a></li>
<li id="menu-item-162325" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-162325"><a href="http://abcnewspapers.com/subscribe/">Subscribe</a></li>
<li id="menu-item-162532" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-162532"><a href="http://abcnewspapers.com/newsstand-locations/">Newsstand Locations</a></li>
<li id="menu-item-171621" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-171621"><a href="http://abcnewspapers.com/links/">Links</a></li>
<li id="menu-item-162324" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-162324"><a href="http://abcnewspapers.com/contact-us/">Contact Us</a></li>
<li id="menu-item-180972" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-180972"><a href="http://theadspider.com">Jobs &#038; Classifieds</a></li>
<li id="menu-item-202272" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-202272"><a href="http://local.abcnewspapers.com/ads">Weekly Print Ads</a></li>
</ul></div></nav>            <header id="masthead">
              <div id="logobar">
                <div id="top-navicon">
                  <div class="nav-icon">
                    <div></div>
                  </div>
                  <div class="nav-description">Sections &amp; Communities</div>
                </div>
                <div id='top-sitelogo'>
                  <a href='http://abcnewspapers.com/' title='ABC Newspapers' rel='home'>
                                          <img src='http://abcnewspapers.com/wp-content/uploads/sites/19/2015/10/abcnewspapers-white1.png' alt='Logo'>
                                      </a>
                </div>
                <div id="top-sitesearch">
                  <form class="top-search-form" action="/">
    <input type="text" value="" id="top-search-input" name="s" placeholder="Search">
    <label id="top-search-label" for="top-search-input">Search</label>
</form>                </div>
              </div>
              
                            <div id="top-adslot">
                <div class="billboard">
                  <script type="text/javascript" src="http://abcnewspapers.com/wp-content/themes/paperboy/js/premiumad.js"></script>
                </div>
              </div>
                          </header>
            <!--END: masthead -->
<div id="story-page">
    <div id="story-content">
        
        <div id="story-meta">
                        <div class="author-outer">
                <div class="author-avatar">
    <img width="140" height="140" src="http://abcnewspapers.com/wp-content/uploads/sites/19/2015/10/Hagen-Eric-140x140.jpg" class="attachment-portrait size-portrait" alt="" /></div><!-- .author-avatar -->

<div class="author-description">
    <div class="author-name">
        By
        <a class="author-link" href="http://abcnewspapers.com/author/ehagen/" rel="author">
            Eric Hagen        </a>
    </div>
    <div class="author-title">
        Staff Writer    </div>
        <div class="author-bio">
        I cover the cities of Andover, Blaine and Ramsey. I have worked at ABC Newspapers since August 2007.    </div><!-- .author-bio -->
        <div class="author-icons">
        <div class="author-twitter social-icon">
                        <a href="https://twitter.com/EricHagenABC" Title="Twitter">
                <svg class="twittersvg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="32px" height="32px" viewBox="0 0 32 32" enable-background="new 0 0 32 32" xml:space="preserve"><g><path d="M0 0v32h32V0H0z M23.943 11.324c-0.066 0.112-0.412 0.508-0.781 0.869c-0.626 0.622-0.66 0.689-0.66 1.2 c0 0.803-0.379 2.475-0.76 3.391c-0.703 1.717-2.213 3.49-3.721 4.383c-2.124 1.254-4.952 1.571-7.333 0.8 c-0.793-0.25-2.156-0.883-2.156-0.996c0-0.033 0.414-0.078 0.917-0.09c1.05-0.023 2.1-0.316 2.995-0.836l0.603-0.361l-0.692-0.237 c-0.985-0.339-1.867-1.119-2.09-1.853c-0.066-0.238-0.045-0.248 0.581-0.248l0.647-0.013l-0.547-0.261 c-0.648-0.326-1.24-0.881-1.531-1.445c-0.212-0.408-0.48-1.436-0.402-1.515c0.022-0.033 0.3 0 0.5 0.1 c0.772 0.3 0.9 0.2 0.424-0.261c-0.837-0.858-1.093-2.135-0.691-3.344l0.189-0.543l0.738 0.7 c1.507 1.5 3.3 2.4 5.3 2.621l0.559 0.068l-0.033-0.553c-0.099-1.436 0.783-2.746 2.18-3.255 c0.514-0.18 1.385-0.203 1.955-0.043c0.225 0.1 0.6 0.3 0.9 0.497l0.548 0.373l0.604-0.193 c0.336-0.101 0.783-0.271 0.982-0.383C23.453 9.9 23.6 9.8 23.6 9.877c0 0.192-0.413 0.848-0.761 1.2 c-0.469 0.509-0.334 0.6 0.6 0.215C24.045 11.1 24.1 11.1 23.9 11.324z" /></g></svg>            </a>
                    </div>
                <div class="author-email social-icon">
            <a href="/cdn-cgi/l/email-protection#abced9c2c885c3cacccec5ebcec8c686c2c5c885c8c4c6" Title="Email">
                <?xml version="1.0" encoding="utf-8"?>
<!-- Generator: Adobe Illustrator 16.0.0, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN" "http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">
<svg class="mailsvg" version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
	 width="32px" height="32px" viewBox="0 0 32 32" enable-background="new 0 0 32 32" xml:space="preserve">
<g>
	<path fill="#FFFFFF" d="M6.127,9.83v12.341h9.872h9.874V9.83h-9.874H6.127z M7.36,11.414l4.203,2.842L7.36,18.84V11.414z
		 M15.999,20.938H8.872l3.514-6.126l3.613,2.442l3.612-2.442l3.516,6.126H15.999z M24.639,18.84l-4.203-4.584l4.203-2.842V18.84z
		 M15.999,15.981l-6.92-4.918h6.92h6.92L15.999,15.981z"/>
	<polygon points="15.999,17.253 12.386,14.811 8.872,20.938 15.999,20.938 23.127,20.938 19.611,14.811 	"/>
	<polygon points="7.36,11.414 7.36,18.84 11.563,14.256 	"/>
	<polygon points="24.639,18.84 24.639,11.414 20.436,14.256 	"/>
	<path d="M0,0v32h32V0H0z M25.873,22.171h-9.874H6.127V9.83h9.872h9.874V22.171z"/>
	<polygon points="9.079,11.063 15.999,15.981 22.919,11.063 15.999,11.063 	"/>
</g>
</svg>
            </a>
        </div>
                    </div>
</div>
            </div>
            <div class="sm-outer">
                <div id="smtool">
    <a href="http://www.facebook.com/sharer.php?u=http://abcnewspapers.com/2017/05/18/blaine-seeks-high-end-grocery-store/"  class="social-icon">
        <svg class="facebooksvg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="32px" height="32px" viewBox="0 0 32 32" enable-background="new 0 0 32 32" xml:space="preserve"><path d="M0 0v32h32V0H0L0 0z M13.741 24.704V16h-1.796v-3h1.796v-1.801 c0-2.447 1.015-3.902 3.897-3.902h2.4v3h-1.5c-1.122 0-1.197 0.42-1.197 1.202L17.338 13h2.717l-0.317 2.999h-2.399v8.705H13.741 L13.741 24.704z M13.741 24.7"/></svg>    </a>
    <a href="http://twitter.com/share?url=http://abcnewspapers.com/2017/05/18/blaine-seeks-high-end-grocery-store/&text=Blaine seeks high-end grocery store"  class="social-icon">
        <svg class="twittersvg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="32px" height="32px" viewBox="0 0 32 32" enable-background="new 0 0 32 32" xml:space="preserve"><g><path d="M0 0v32h32V0H0z M23.943 11.324c-0.066 0.112-0.412 0.508-0.781 0.869c-0.626 0.622-0.66 0.689-0.66 1.2 c0 0.803-0.379 2.475-0.76 3.391c-0.703 1.717-2.213 3.49-3.721 4.383c-2.124 1.254-4.952 1.571-7.333 0.8 c-0.793-0.25-2.156-0.883-2.156-0.996c0-0.033 0.414-0.078 0.917-0.09c1.05-0.023 2.1-0.316 2.995-0.836l0.603-0.361l-0.692-0.237 c-0.985-0.339-1.867-1.119-2.09-1.853c-0.066-0.238-0.045-0.248 0.581-0.248l0.647-0.013l-0.547-0.261 c-0.648-0.326-1.24-0.881-1.531-1.445c-0.212-0.408-0.48-1.436-0.402-1.515c0.022-0.033 0.3 0 0.5 0.1 c0.772 0.3 0.9 0.2 0.424-0.261c-0.837-0.858-1.093-2.135-0.691-3.344l0.189-0.543l0.738 0.7 c1.507 1.5 3.3 2.4 5.3 2.621l0.559 0.068l-0.033-0.553c-0.099-1.436 0.783-2.746 2.18-3.255 c0.514-0.18 1.385-0.203 1.955-0.043c0.225 0.1 0.6 0.3 0.9 0.497l0.548 0.373l0.604-0.193 c0.336-0.101 0.783-0.271 0.982-0.383C23.453 9.9 23.6 9.8 23.6 9.877c0 0.192-0.413 0.848-0.761 1.2 c-0.469 0.509-0.334 0.6 0.6 0.215C24.045 11.1 24.1 11.1 23.9 11.324z" /></g></svg>    </a>
    <a href="https://plus.google.com/share?url=http://abcnewspapers.com/2017/05/18/blaine-seeks-high-end-grocery-store/"  class="social-icon">
      <svg class="googlepsvg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="32px" height="32px" viewBox="0 0 32 32" enable-background="new 0 0 32 32" xml:space="preserve"><g><path d="M8.704 25.305c-0.373-0.05-0.608-0.05-1.075-0.05c-0.425 0-2.96 0.095-4.932 0.8 c-0.677 0.247-1.848 0.406-2.817 1.721V32h14.68c0.01-0.132 0.009-0.221 0.009-0.475C14.569 29.1 12.3 27.9 8.7 25.305z" class="style0"/><path d="M11.409 12.914c0-3.394-1.966-8.67-5.861-8.67c-1.222 0-2.535 0.611-3.287 1.6 C1.464 6.8 1.3 8.1 1.3 9.286c0 3.2 1.7 7.8 5.7 7.823c1.173 0 2.376-0.299 3.148-1.179 C11.063 14.9 11.4 13.6 11.4 12.914z" class="style0"/><rect x="-0.1" y="25.3" width="0" height="2.5" class="style0"/><path d="M5.702 20.732c0-0.799 0.235-1.271 0.469-1.838c-0.517 0.047-1.032 0.095-1.502 0.1 c-2.13 0-3.502-0.455-4.789-1.524v7.797c2.68-1.15 5.437-1.205 7.23-1.326C6.452 23.1 5.7 22.2 5.7 20.732z" class="style0"/><path d="M-0.12 5.28c2.676-2.216 5.614-2.585 8.077-2.631h9.92l-2.635 2.126h-2.877 c1.153 1 2.9 2.8 2.9 5.969c0 3.486-1.837 5.138-3.809 6.691c-0.611 0.611-1.314 1.272-1.314 2.3 c0 1 0.7 1.6 1.2 2.023l1.692 1.317c2.065 1.7 4.8 3.3 4.8 6.599c0 0.873-0.145 1.424-0.418 2.313L14.56 32h17.32 V11.072h-5.976v6.005h-2.551v-6.005H17.4v-2.5h5.953V2.619h2.551v5.953h5.976V0h-32V5.28z" class="style0"/></g></svg>
    </a>
    <a href="/cdn-cgi/l/email-protection#8cb3fff9eee6e9eff8b1cee0ede5e2e9acffe9e9e7fface4e5ebe4a1e9e2e8acebfee3efe9fef5acfff8e3fee9aaeee3e8f5b1a9bebce4f8f8fcb6a3a3edeeefe2e9fbfffcedfce9feffa2efe3e1a3bebcbdbba3bcb9a3bdb4a3eee0ede5e2e9a1ffe9e9e7ffa1e4e5ebe4a1e9e2e8a1ebfee3efe9fef5a1fff8e3fee9a3" class="social-icon">
        <?xml version="1.0" encoding="utf-8"?>
<!-- Generator: Adobe Illustrator 16.0.0, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN" "http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">
<svg class="mailsvg" version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
	 width="32px" height="32px" viewBox="0 0 32 32" enable-background="new 0 0 32 32" xml:space="preserve">
<g>
	<path fill="#FFFFFF" d="M6.127,9.83v12.341h9.872h9.874V9.83h-9.874H6.127z M7.36,11.414l4.203,2.842L7.36,18.84V11.414z
		 M15.999,20.938H8.872l3.514-6.126l3.613,2.442l3.612-2.442l3.516,6.126H15.999z M24.639,18.84l-4.203-4.584l4.203-2.842V18.84z
		 M15.999,15.981l-6.92-4.918h6.92h6.92L15.999,15.981z"/>
	<polygon points="15.999,17.253 12.386,14.811 8.872,20.938 15.999,20.938 23.127,20.938 19.611,14.811 	"/>
	<polygon points="7.36,11.414 7.36,18.84 11.563,14.256 	"/>
	<polygon points="24.639,18.84 24.639,11.414 20.436,14.256 	"/>
	<path d="M0,0v32h32V0H0z M25.873,22.171h-9.874H6.127V9.83h9.872h9.874V22.171z"/>
	<polygon points="9.079,11.063 15.999,15.981 22.919,11.063 15.999,11.063 	"/>
</g>
</svg>
    </a>
    <a href="javascript:window.print()" class="social-icon">
        <?xml version="1.0" encoding="utf-8"?>
<!-- Generator: Adobe Illustrator 16.0.0, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN" "http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">
<svg class="printsvg" version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
	 width="32px" height="32px" viewBox="0 0 32 32" enable-background="new 0 0 32 32" xml:space="preserve">
<g>
	<path  d="M13.933,23.965h4.134c0.213,0,0.385-0.172,0.385-0.385c0-0.088-0.031-0.172-0.082-0.234
		c-0.07-0.09-0.178-0.148-0.305-0.148h-4.132c-0.123,0-0.232,0.057-0.301,0.148c-0.051,0.062-0.08,0.146-0.08,0.234
		C13.552,23.791,13.722,23.965,13.933,23.965z"/>
	<path  d="M22.889,13.762c-0.006,0-0.008,0-0.014,0h-1.203h-0.346h-0.352h-0.334c-0.324,0-0.584,0.262-0.584,0.584
		v0.42c0,0.154,0.059,0.293,0.156,0.396c0.105,0.115,0.258,0.188,0.428,0.188h0.686h0.346h0.779h0.424
		c0.322,0,0.582-0.262,0.582-0.584v-0.42C23.457,14.028,23.205,13.77,22.889,13.762z"/>
	<path  d="M13.933,22.092h4.132c0.211,0,0.385-0.174,0.385-0.385c0-0.209-0.17-0.383-0.385-0.383h-4.132
		c-0.211,0-0.381,0.174-0.381,0.383C13.552,21.918,13.722,22.092,13.933,22.092z"/>
	<path  d="M0,0v32h32V0H0z M21.672,6.528h0.049c0.645,0,1.168,0.523,1.168,1.17v3.689h-1.217V6.528z M11.024,6.528
		V6.481c0-0.643,0.521-1.166,1.168-1.166h7.612c0.645,0,1.17,0.523,1.17,1.166v0.047v4.859h-9.95V6.528z M9.108,7.698
		c0-0.646,0.523-1.17,1.168-1.17h0.047v4.859H9.108V7.698z M20.975,22.645v0.35v0.35v2.174c0,0.645-0.525,1.168-1.17,1.168h-7.612
		c-0.646,0-1.168-0.523-1.168-1.168v-2.174v-0.35v-0.35v-2.629h9.95V22.645z M26.475,21.475c0,0.646-0.525,1.17-1.17,1.17h-3.752
		v-2.629h0.973c0.209,0,0.381-0.174,0.381-0.385s-0.17-0.383-0.381-0.383H9.474c-0.213,0-0.383,0.172-0.383,0.383
		s0.168,0.385,0.383,0.385h0.969v2.629H6.69c-0.645,0-1.168-0.523-1.166-1.17v-8.22c0-0.645,0.523-1.168,1.168-1.168h2.416h1.215
		h0.352h0.35h9.95h0.352h0.346h1.217h2.416c0.645,0,1.17,0.523,1.17,1.168V21.475z"/>
</g>
</svg>
    </a>
</div>
            </div>
                    </div>
        <main id="story-posts" class="site-main" role="main">
            <!-- SET: Advice IQ Advisors -->
<!-- END: Advice IQ Advisors -->
            <article id="post-202684" class="post-202684 post type-post status-publish format-standard hentry category-business category-government tag-blaine">
    <header class="entry-header">
                <div class="entry-category"><a href="http://abcnewspapers.com/category/business/" rel="category tag">Business</a> &bull; <a href="http://abcnewspapers.com/category/government/" rel="category tag">Government</a></div>
        <h1 class="entry-title">Blaine seeks high-end grocery store</h1>
        <time class="dt-published published" itemprop="datePublished" datetime="2017-05-18T16:15:09+00:00">
            Published May 18, 2017 at 4:15 pm        </time>

        <div class="author-inner">
            <div class="author-avatar">
    <img width="140" height="140" src="http://abcnewspapers.com/wp-content/uploads/sites/19/2015/10/Hagen-Eric-140x140.jpg" class="attachment-portrait size-portrait" alt="" /></div><!-- .author-avatar -->

<div class="author-description">
    <div class="author-name">
        By
        <a class="author-link" href="http://abcnewspapers.com/author/ehagen/" rel="author">
            Eric Hagen        </a>
    </div>
    <div class="author-title">
        Staff Writer    </div>
        <div class="author-bio">
        I cover the cities of Andover, Blaine and Ramsey. I have worked at ABC Newspapers since August 2007.    </div><!-- .author-bio -->
        <div class="author-icons">
        <div class="author-twitter social-icon">
                        <a href="https://twitter.com/EricHagenABC" Title="Twitter">
                <svg class="twittersvg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="32px" height="32px" viewBox="0 0 32 32" enable-background="new 0 0 32 32" xml:space="preserve"><g><path d="M0 0v32h32V0H0z M23.943 11.324c-0.066 0.112-0.412 0.508-0.781 0.869c-0.626 0.622-0.66 0.689-0.66 1.2 c0 0.803-0.379 2.475-0.76 3.391c-0.703 1.717-2.213 3.49-3.721 4.383c-2.124 1.254-4.952 1.571-7.333 0.8 c-0.793-0.25-2.156-0.883-2.156-0.996c0-0.033 0.414-0.078 0.917-0.09c1.05-0.023 2.1-0.316 2.995-0.836l0.603-0.361l-0.692-0.237 c-0.985-0.339-1.867-1.119-2.09-1.853c-0.066-0.238-0.045-0.248 0.581-0.248l0.647-0.013l-0.547-0.261 c-0.648-0.326-1.24-0.881-1.531-1.445c-0.212-0.408-0.48-1.436-0.402-1.515c0.022-0.033 0.3 0 0.5 0.1 c0.772 0.3 0.9 0.2 0.424-0.261c-0.837-0.858-1.093-2.135-0.691-3.344l0.189-0.543l0.738 0.7 c1.507 1.5 3.3 2.4 5.3 2.621l0.559 0.068l-0.033-0.553c-0.099-1.436 0.783-2.746 2.18-3.255 c0.514-0.18 1.385-0.203 1.955-0.043c0.225 0.1 0.6 0.3 0.9 0.497l0.548 0.373l0.604-0.193 c0.336-0.101 0.783-0.271 0.982-0.383C23.453 9.9 23.6 9.8 23.6 9.877c0 0.192-0.413 0.848-0.761 1.2 c-0.469 0.509-0.334 0.6 0.6 0.215C24.045 11.1 24.1 11.1 23.9 11.324z" /></g></svg>            </a>
                    </div>
                <div class="author-email social-icon">
            <a href="/cdn-cgi/l/email-protection#95f0e7fcf6bbfdf4f2f0fbd5f0f6f8b8fcfbf6bbf6faf8" Title="Email">
                <?xml version="1.0" encoding="utf-8"?>
<!-- Generator: Adobe Illustrator 16.0.0, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN" "http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">
<svg class="mailsvg" version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
	 width="32px" height="32px" viewBox="0 0 32 32" enable-background="new 0 0 32 32" xml:space="preserve">
<g>
	<path fill="#FFFFFF" d="M6.127,9.83v12.341h9.872h9.874V9.83h-9.874H6.127z M7.36,11.414l4.203,2.842L7.36,18.84V11.414z
		 M15.999,20.938H8.872l3.514-6.126l3.613,2.442l3.612-2.442l3.516,6.126H15.999z M24.639,18.84l-4.203-4.584l4.203-2.842V18.84z
		 M15.999,15.981l-6.92-4.918h6.92h6.92L15.999,15.981z"/>
	<polygon points="15.999,17.253 12.386,14.811 8.872,20.938 15.999,20.938 23.127,20.938 19.611,14.811 	"/>
	<polygon points="7.36,11.414 7.36,18.84 11.563,14.256 	"/>
	<polygon points="24.639,18.84 24.639,11.414 20.436,14.256 	"/>
	<path d="M0,0v32h32V0H0z M25.873,22.171h-9.874H6.127V9.83h9.872h9.874V22.171z"/>
	<polygon points="9.079,11.063 15.999,15.981 22.919,11.063 15.999,11.063 	"/>
</g>
</svg>
            </a>
        </div>
                    </div>
</div>
        </div>
      </header><!-- .entry-header -->
<div class="entry-content">
    <p>The city of Blaine knows there’s demand from residents for more grocery store options in Blaine.
<p>One of the big tasks for Blaine Economic Development Coordinator Erik Thorvig is recruiting new businesses, although the city would be limited on what it could do in private market transactions when no city land is involved.<span class="wp-caption alignright"><script type="text/javascript">broadstreet.zone(47118);</script></span>
<p>But considering the ongoing interest from residents and the Blaine City Council in getting more high-end grocery stores in Blaine, Thorvig reached out to representatives from six different companies to gauge their interest in the community. He shared the feedback at the May 11 council workshop.
<p>Thorvig contacted Hy-Vee, Whole Foods, Fresh Thyme, Kowalski’s, Lund’s/Byerly’s and Trader Joe’s. He was unable to reach anyone from Trader Joe’s before the May 11, but he did get responses from the other five companies.
<p>According to Thorvig’s summary, Hy-Vee is actively searching for a site in Blaine. In general, he said Hy-Vee is looking for 14 acres with the possibility of having a liquor store and gas station as part of the development but they did not indicate whether those would be deal breakers for a site.
<p>“Our hope is not if but when with Hy-Vee,” Thorvig told the council. “We know they’re doing their due diligence.”
<p>A real estate representative for Whole Foods indicated they would not be building any new traditional stores in Minnesota after their Woodbury store is complete. But the company has a new 365 by Whole Foods concept, which is a smaller store selling products at lower prices. This concept has yet to come to Minnesota, but Thorvig said the representative indicated Blaine might be a good fit.<div class="instory-ad" id="video_play_on_view"><script type="text/javascript">broadstreet.zone(48407);</script></div>
<p>Fresh Thyme is looking at opening a store in Coon Rapids, but said they would look again at Blaine if that store does not materialize, according to a conversation Thorvig had with a Fresh Thyme real estate staff member.
<p>Kowalkski’s real estate staff member said the company is busy with a major remodel of its Uptown Minneapolis store on Hennepin Avenue and just opened a store in Shoreview last fall and is not looking at doing anything new at this time.
<p>Lund’s and Byerly’s is also currently holding off on any expansion plans, Thorvig said.
<p>Council Member Dick Swanson has been impressed with the Festival Foods stores he has seen in Wisconsin and said it would be worthwhile to talk to even more grocers to see if they could bring a new quality store to Blaine.
<p>Council Member Andrew Garvais would like Thorvig and Blaine staff continue to work hard to recruit a high-end grocery retailer to Blaine. The city rents a tent each year at 3M Championship in Blaine each year and hosts prospective developers. He would like the city to invite grocery retailers so the city can do another recruiting pitch.
<p>“I think this will be a good year to lock down one of these,” Garvais said.
<p><a href="/cdn-cgi/l/email-protection#f396819a90dd9b9294969db396909ede9a9d90dd909c9e"><strong><span class="__cf_email__" data-cfemail="cbaeb9a2a8e5a3aaacaea58baea8a6e6a2a5a8e5a8a4a6">[email&#160;protected]</span><script data-cfhash='f9e31' type="text/javascript">/* <![CDATA[ */!function(t,e,r,n,c,a,p){try{t=document.currentScript||function(){for(t=document.getElementsByTagName('script'),e=t.length;e--;)if(t[e].getAttribute('data-cfhash'))return t[e]}();if(t&&(c=t.previousSibling)){p=t.parentNode;if(a=c.getAttribute('data-cfemail')){for(e='',r='0x'+a.substr(0,2)|0,n=2;a.length-n;n+=2)e+='%'+('0'+('0x'+a.substr(n,2)^r).toString(16)).slice(-2);p.replaceChild(document.createTextNode(decodeURIComponent(e)),c)}p.removeChild(t)}}catch(u){}}()/* ]]> */</script></strong></a>
<!-- p_total: 15 -->    </div><!-- .entry-content -->
    <footer class="entry-footer">
        <div class="sm-inner">
            <div id="smtool">
    <a href="http://www.facebook.com/sharer.php?u=http://abcnewspapers.com/2017/05/18/blaine-seeks-high-end-grocery-store/"  class="social-icon">
        <svg class="facebooksvg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="32px" height="32px" viewBox="0 0 32 32" enable-background="new 0 0 32 32" xml:space="preserve"><path d="M0 0v32h32V0H0L0 0z M13.741 24.704V16h-1.796v-3h1.796v-1.801 c0-2.447 1.015-3.902 3.897-3.902h2.4v3h-1.5c-1.122 0-1.197 0.42-1.197 1.202L17.338 13h2.717l-0.317 2.999h-2.399v8.705H13.741 L13.741 24.704z M13.741 24.7"/></svg>    </a>
    <a href="http://twitter.com/share?url=http://abcnewspapers.com/2017/05/18/blaine-seeks-high-end-grocery-store/&text=Blaine seeks high-end grocery store"  class="social-icon">
        <svg class="twittersvg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="32px" height="32px" viewBox="0 0 32 32" enable-background="new 0 0 32 32" xml:space="preserve"><g><path d="M0 0v32h32V0H0z M23.943 11.324c-0.066 0.112-0.412 0.508-0.781 0.869c-0.626 0.622-0.66 0.689-0.66 1.2 c0 0.803-0.379 2.475-0.76 3.391c-0.703 1.717-2.213 3.49-3.721 4.383c-2.124 1.254-4.952 1.571-7.333 0.8 c-0.793-0.25-2.156-0.883-2.156-0.996c0-0.033 0.414-0.078 0.917-0.09c1.05-0.023 2.1-0.316 2.995-0.836l0.603-0.361l-0.692-0.237 c-0.985-0.339-1.867-1.119-2.09-1.853c-0.066-0.238-0.045-0.248 0.581-0.248l0.647-0.013l-0.547-0.261 c-0.648-0.326-1.24-0.881-1.531-1.445c-0.212-0.408-0.48-1.436-0.402-1.515c0.022-0.033 0.3 0 0.5 0.1 c0.772 0.3 0.9 0.2 0.424-0.261c-0.837-0.858-1.093-2.135-0.691-3.344l0.189-0.543l0.738 0.7 c1.507 1.5 3.3 2.4 5.3 2.621l0.559 0.068l-0.033-0.553c-0.099-1.436 0.783-2.746 2.18-3.255 c0.514-0.18 1.385-0.203 1.955-0.043c0.225 0.1 0.6 0.3 0.9 0.497l0.548 0.373l0.604-0.193 c0.336-0.101 0.783-0.271 0.982-0.383C23.453 9.9 23.6 9.8 23.6 9.877c0 0.192-0.413 0.848-0.761 1.2 c-0.469 0.509-0.334 0.6 0.6 0.215C24.045 11.1 24.1 11.1 23.9 11.324z" /></g></svg>    </a>
    <a href="https://plus.google.com/share?url=http://abcnewspapers.com/2017/05/18/blaine-seeks-high-end-grocery-store/"  class="social-icon">
      <svg class="googlepsvg" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" version="1.1" x="0px" y="0px" width="32px" height="32px" viewBox="0 0 32 32" enable-background="new 0 0 32 32" xml:space="preserve"><g><path d="M8.704 25.305c-0.373-0.05-0.608-0.05-1.075-0.05c-0.425 0-2.96 0.095-4.932 0.8 c-0.677 0.247-1.848 0.406-2.817 1.721V32h14.68c0.01-0.132 0.009-0.221 0.009-0.475C14.569 29.1 12.3 27.9 8.7 25.305z" class="style0"/><path d="M11.409 12.914c0-3.394-1.966-8.67-5.861-8.67c-1.222 0-2.535 0.611-3.287 1.6 C1.464 6.8 1.3 8.1 1.3 9.286c0 3.2 1.7 7.8 5.7 7.823c1.173 0 2.376-0.299 3.148-1.179 C11.063 14.9 11.4 13.6 11.4 12.914z" class="style0"/><rect x="-0.1" y="25.3" width="0" height="2.5" class="style0"/><path d="M5.702 20.732c0-0.799 0.235-1.271 0.469-1.838c-0.517 0.047-1.032 0.095-1.502 0.1 c-2.13 0-3.502-0.455-4.789-1.524v7.797c2.68-1.15 5.437-1.205 7.23-1.326C6.452 23.1 5.7 22.2 5.7 20.732z" class="style0"/><path d="M-0.12 5.28c2.676-2.216 5.614-2.585 8.077-2.631h9.92l-2.635 2.126h-2.877 c1.153 1 2.9 2.8 2.9 5.969c0 3.486-1.837 5.138-3.809 6.691c-0.611 0.611-1.314 1.272-1.314 2.3 c0 1 0.7 1.6 1.2 2.023l1.692 1.317c2.065 1.7 4.8 3.3 4.8 6.599c0 0.873-0.145 1.424-0.418 2.313L14.56 32h17.32 V11.072h-5.976v6.005h-2.551v-6.005H17.4v-2.5h5.953V2.619h2.551v5.953h5.976V0h-32V5.28z" class="style0"/></g></svg>
    </a>
    <a href="/cdn-cgi/l/email-protection#1a25696f78707f796e2758767b73747f3a697f7f71693a72737d72377f747e3a7d6875797f68633a696e75687f3c78757e63273f282a726e6e6a2035357b7879747f6d696a7b6a7f68693479757735282a2b2d352a2f352b223578767b73747f37697f7f71693772737d72377f747e377d6875797f686337696e75687f35" class="social-icon">
        <?xml version="1.0" encoding="utf-8"?>
<!-- Generator: Adobe Illustrator 16.0.0, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN" "http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">
<svg class="mailsvg" version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
	 width="32px" height="32px" viewBox="0 0 32 32" enable-background="new 0 0 32 32" xml:space="preserve">
<g>
	<path fill="#FFFFFF" d="M6.127,9.83v12.341h9.872h9.874V9.83h-9.874H6.127z M7.36,11.414l4.203,2.842L7.36,18.84V11.414z
		 M15.999,20.938H8.872l3.514-6.126l3.613,2.442l3.612-2.442l3.516,6.126H15.999z M24.639,18.84l-4.203-4.584l4.203-2.842V18.84z
		 M15.999,15.981l-6.92-4.918h6.92h6.92L15.999,15.981z"/>
	<polygon points="15.999,17.253 12.386,14.811 8.872,20.938 15.999,20.938 23.127,20.938 19.611,14.811 	"/>
	<polygon points="7.36,11.414 7.36,18.84 11.563,14.256 	"/>
	<polygon points="24.639,18.84 24.639,11.414 20.436,14.256 	"/>
	<path d="M0,0v32h32V0H0z M25.873,22.171h-9.874H6.127V9.83h9.872h9.874V22.171z"/>
	<polygon points="9.079,11.063 15.999,15.981 22.919,11.063 15.999,11.063 	"/>
</g>
</svg>
    </a>
    <a href="javascript:window.print()" class="social-icon">
        <?xml version="1.0" encoding="utf-8"?>
<!-- Generator: Adobe Illustrator 16.0.0, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN" "http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">
<svg class="printsvg" version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
	 width="32px" height="32px" viewBox="0 0 32 32" enable-background="new 0 0 32 32" xml:space="preserve">
<g>
	<path  d="M13.933,23.965h4.134c0.213,0,0.385-0.172,0.385-0.385c0-0.088-0.031-0.172-0.082-0.234
		c-0.07-0.09-0.178-0.148-0.305-0.148h-4.132c-0.123,0-0.232,0.057-0.301,0.148c-0.051,0.062-0.08,0.146-0.08,0.234
		C13.552,23.791,13.722,23.965,13.933,23.965z"/>
	<path  d="M22.889,13.762c-0.006,0-0.008,0-0.014,0h-1.203h-0.346h-0.352h-0.334c-0.324,0-0.584,0.262-0.584,0.584
		v0.42c0,0.154,0.059,0.293,0.156,0.396c0.105,0.115,0.258,0.188,0.428,0.188h0.686h0.346h0.779h0.424
		c0.322,0,0.582-0.262,0.582-0.584v-0.42C23.457,14.028,23.205,13.77,22.889,13.762z"/>
	<path  d="M13.933,22.092h4.132c0.211,0,0.385-0.174,0.385-0.385c0-0.209-0.17-0.383-0.385-0.383h-4.132
		c-0.211,0-0.381,0.174-0.381,0.383C13.552,21.918,13.722,22.092,13.933,22.092z"/>
	<path  d="M0,0v32h32V0H0z M21.672,6.528h0.049c0.645,0,1.168,0.523,1.168,1.17v3.689h-1.217V6.528z M11.024,6.528
		V6.481c0-0.643,0.521-1.166,1.168-1.166h7.612c0.645,0,1.17,0.523,1.17,1.166v0.047v4.859h-9.95V6.528z M9.108,7.698
		c0-0.646,0.523-1.17,1.168-1.17h0.047v4.859H9.108V7.698z M20.975,22.645v0.35v0.35v2.174c0,0.645-0.525,1.168-1.17,1.168h-7.612
		c-0.646,0-1.168-0.523-1.168-1.168v-2.174v-0.35v-0.35v-2.629h9.95V22.645z M26.475,21.475c0,0.646-0.525,1.17-1.17,1.17h-3.752
		v-2.629h0.973c0.209,0,0.381-0.174,0.381-0.385s-0.17-0.383-0.381-0.383H9.474c-0.213,0-0.383,0.172-0.383,0.383
		s0.168,0.385,0.383,0.385h0.969v2.629H6.69c-0.645,0-1.168-0.523-1.166-1.17v-8.22c0-0.645,0.523-1.168,1.168-1.168h2.416h1.215
		h0.352h0.35h9.95h0.352h0.346h1.217h2.416c0.645,0,1.17,0.523,1.17,1.168V21.475z"/>
</g>
</svg>
    </a>
</div>
        </div>
        <div class="filed-under">
            Filed Under: <a href="http://abcnewspapers.com/tag/blaine/" rel="tag">Blaine</a><br />        </div>
            </footer><!-- .entry-footer -->
        </article><!-- #post-## -->
            
	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="http://abcnewspapers.com/2017/05/18/grand-opening-set-for-renovated-sand-creek-park/" rel="prev"><span class="meta-nav" aria-hidden="true">&laquo; Previous</span> </a></div></div>
	</nav>                <!-- Outbrain -->
                <div class="OUTBRAIN" data-widget-id="TF_6" data-src="" data-ob-template="ECMPublishers"></div>

                <div id="comments">
                    
<div id="disqus_thread">
    </div>

                </div>

                
            </main><!-- .site-main -->
            <div id="story-sidebar">
                    <div id="sidebar" >
        <aside class="widget-1 widget-first widget-odd widget">
<div id="aeris-w0" class="aeris-widget aeris-widget-24hr-compact ">
    <div class="aeris-widget-content aeris-widget-24hr-compact-content" style="display: none;">
        <div class="aeris-widget-outer aeris-widget-24hr-compact">
            <div class="aeris-widget-inner">
                <div class="aeris-widget-24hr-compact-now" style>
                    <div class="aeris-widget-24hr-compact-pad">
                        <div class="aeris-widget-24hr-compact-title" id="weather-location" style="margin-top: 0"></div>
                        <div class="aeris-widget-24hr-compact-icon"><img id="now-icon" src=""></div>
                        <div class="aeris-widget-24hr-compact-temp" id="now-temp"></div>
                    </div>
                    <div class="topcorner" style="position: absolute;bottom: 0px;left: 48px;font-size: 7pt;padding: 2px 4px;background-color: #005e9e;color: #ffffff;">Click for Weather</div>
                </div>
                <div class="aeris-widget-24hr-compact-periods">
                    <div class="aeris-widget-24hr-compact-period">
                        <div class="aeris-widget-24hr-compact-title">Today</div>
                        <div class="aeris-widget-24hr-compact-pad">
                            <div class="aeris-widget-24hr-compact-icon">
                                <img id="max-icon" src="">
                            </div><div class="aeris-widget-24hr-compact-temp" id="max-temp"></div>
                        </div>
                    </div>
                    <div class="aeris-widget-24hr-compact-period aeris-widget-24hr-compact-period-last">
                        <div class="aeris-widget-24hr-compact-title">Tonight</div>
                        <div class="aeris-widget-24hr-compact-pad">
                            <div class="aeris-widget-24hr-compact-icon">
                                <img id="min-icon" src="">
                            </div>
                            <div class="aeris-widget-24hr-compact-temp" id="min-temp"></div>
                        </div>
                    </div>
                </div>
            </div>
        </div>
    </div>
    <div class="aeris-widget-loader aeris-widget-24hr-compact-loader" style="width: 300px; height: 50px; display: block;">
    </div>
</div>
<script type="text/javascript">

    jQuery(document).ready(function($){
        jQuery('.aeris-widget-loader').html('<img src="http://abcnewspapers.com/wp-content/plugins/ecm-weather/images/loader.GIF" />')
        jQuery.ajax({
            type:"POST",url:"http://abcnewspapers.com/wp-admin/admin-ajax.php",
            data:"action=ecmw_get_weather_for_widget",
            success:function(html){
                var data = jQuery.parseJSON(html);
                if(data.nowTemp != null) {
                    $('#now-temp').html(data.nowTemp);
                    $('#weather-location').html(data.city);
                    $('#now-desc').html(data.nowDesc);
                    $('#now-icon').attr('src','http://abcnewspapers.com/wp-content/plugins/ecm-weather//images/ICO/' + data.nowIcon );
                    $('#max-temp').html(data.maxTemp);
                    $('#max-icon').attr('src','http://abcnewspapers.com/wp-content/plugins/ecm-weather//images/ICO/' + data.maxTempIcon );
                    $('#min-temp').html(data.minTemp);
                    $('#min-icon').attr('src','http://abcnewspapers.com/wp-content/plugins/ecm-weather//images/ICO/' + data.minTempIcon );
                    $('.aeris-widget-loader').hide();
                    $('.aeris-widget-content').show();
                    $('.aeris-widget-content').mouseover(function(){
                        if(data.weatherPage != '')
                            $('.aeris-widget-content').css('cursor','pointer');
                    });
                    $('.aeris-widget-content').click(function(){
                        window.location = data.weatherPage ;
                    });

                }
            }
        });
    });
</script></aside><aside class="widget-2 widget-even widget">			<div class="textwidget"><div style="width:320px;height:50px">
<script type="text/javascript">broadstreet.zone(43521);</script>
</div>
</div>
		</aside><aside class="widget-3 widget-odd widget"><h2>Upcoming Events</h2>
	<ol class="tribe-list-widget">
					<li class="tribe-events-list-widget-events type-tribe_events post-202776 tribe-clearfix tribe-events-venue-202778">

								<!-- Event Title -->
				<h4 class="tribe-event-title">
					<a href="http://abcnewspapers.com/event/city-of-ramsey-garden-club-plant-sale-2/" rel="bookmark">City of Ramsey Garden Club Plant Sale</a>
				</h4>

								<!-- Event Time -->

				
				<div class="tribe-event-duration">
					<span class="tribe-event-date-start">May 20 @ 8:00 am</span> - <span class="tribe-event-time">12:00 pm</span>				</div>

							</li>
					<li class="tribe-events-list-widget-events type-tribe_events post-202779 tribe-clearfix tribe-events-venue-164348">

								<!-- Event Title -->
				<h4 class="tribe-event-title">
					<a href="http://abcnewspapers.com/event/perennial-plant-sale-3/" rel="bookmark">Perennial Plant Sale</a>
				</h4>

								<!-- Event Time -->

				
				<div class="tribe-event-duration">
					<span class="tribe-event-date-start">May 20 @ 8:00 am</span> - <span class="tribe-event-time">12:00 pm</span>				</div>

							</li>
					<li class="tribe-events-list-widget-events type-tribe_events post-201570 tribe-clearfix tribe-events-venue-172979">

								<!-- Event Title -->
				<h4 class="tribe-event-title">
					<a href="http://abcnewspapers.com/event/walk-a-mile-in-her-shoes-2/" rel="bookmark">CANCELED &#8211; Walk A Mile In Her Shoes</a>
				</h4>

								<!-- Event Time -->

				
				<div class="tribe-event-duration">
					<span class="tribe-event-date-start">May 20 @ 8:30 am</span> - <span class="tribe-event-time">12:30 pm</span>				</div>

							</li>
					<li class="tribe-events-list-widget-events type-tribe_events post-202208 tribe-clearfix tribe-events-venue-187143">

								<!-- Event Title -->
				<h4 class="tribe-event-title">
					<a href="http://abcnewspapers.com/event/nusrat-mosque-open-house-series-2/" rel="bookmark">Nusrat Mosque Open House Series</a>
				</h4>

								<!-- Event Time -->

				
				<div class="tribe-event-duration">
					<span class="tribe-event-date-start">May 20 @ 7:00 pm</span> - <span class="tribe-event-time">9:00 pm</span>				</div>

							</li>
			</ol><!-- .tribe-list-widget -->

	<p class="tribe-events-widget-link">
		<a href="http://abcnewspapers.com/events/" rel="bookmark">View All Events</a>
	</p>

</aside><script type="application/ld+json">
[{"@context":"http://schema.org","@type":"Event","name":"City of Ramsey Garden Club Plant Sale","description":"&lt;p&gt;When: 8 a.m. to noon Where: Ramsey Municipal Center (City Hall), 7550 Sunwood Drive NW&lt;/p&gt;\\n","url":"http://abcnewspapers.com/event/city-of-ramsey-garden-club-plant-sale-2/","startDate":"2017-05-20T13:00:00+00:00","endDate":"2017-05-20T17:00:00+00:00","location":{"@type":"Place","name":"Ramsey Municipal Center","description":"","url":"http://abcnewspapers.com/venue/ramsey-municipal-center/","address":{"streetAddress":"7550 Sunwood Drive NW","addressLocality":"Ramsey","addressCountry":"United States"},"telephone":"","sameAs":""}},{"@context":"http://schema.org","@type":"Event","name":"Perennial Plant Sale","description":"&lt;p&gt;When: May 20, 8 a.m. to noon; May 21, 9 a.m. to noon Where: Lord of Life Church, 14501 Nowthen Blvd., Ramsey Info: Large selection of perennial plants that come from the church and member gardens. Most cost $2 to $5. Proceeds used to maintain church gardens and fund church projects.&lt;/p&gt;\\n","url":"http://abcnewspapers.com/event/perennial-plant-sale-3/","startDate":"2017-05-20T13:00:00+00:00","endDate":"2017-05-20T17:00:00+00:00","location":{"@type":"Place","name":"Lord of Life Church","description":"","url":"http://abcnewspapers.com/venue/lord-of-life-church/","address":{"streetAddress":"14501 Nowthen Blvd","addressLocality":"Ramsey","addressRegion":"MN","addressCountry":"United States"},"telephone":"","sameAs":""}},{"@context":"http://schema.org","@type":"Event","name":"CANCELED &#8211; Walk A Mile In Her Shoes","description":"&lt;p&gt;The event has been canceled with inclement weather expected May 20. When: Registration/check-in, 8:30-10:15 a.m.; opening remarks and walk kick-off 10:15-10:30 a.m.; walk and awards, 10:30-11:30 a.m.; resource fair and team photos, 11:30 a.m. to 12:30 p.m. Where:\u00a0Anoka City Hall Plaza, 2015 First Ave. Info: An international men\\'s march to end rape, sexual assault and...&lt;/p&gt;\\n","url":"http://abcnewspapers.com/event/walk-a-mile-in-her-shoes-2/","startDate":"2017-05-20T13:30:00+00:00","endDate":"2017-05-20T17:30:00+00:00","location":{"@type":"Place","name":"Anoka City Hall Plaza","description":"","url":"http://abcnewspapers.com/venue/anoka-city-hall-plaza/","address":{"streetAddress":"2015 First Ave. S","addressLocality":"Anoka","addressRegion":"MN","postalCode":"55303","addressCountry":"United States"},"telephone":"","sameAs":""}},{"@context":"http://schema.org","@type":"Event","name":"Nusrat Mosque Open House Series","description":"&lt;p&gt;When: 7-9 p.m. Where: Nusrat Mosque, 11450 Robinson Drive, Coon Rapids Info: The mosque opens its doors to everyone who would like an opportunity to meet a Muslim and ask any questions on his or her mind about Islam. No question will be considered offensive! May\u2019s discussion topic: Is Extremism inspired by Quran? Contact nusratmosque@gmail.com...&lt;/p&gt;\\n","url":"http://abcnewspapers.com/event/nusrat-mosque-open-house-series-2/","startDate":"2017-05-21T00:00:00+00:00","endDate":"2017-05-21T02:00:00+00:00","location":{"@type":"Place","name":"Nusrat Mosque","description":"","url":"http://abcnewspapers.com/venue/nusrat-mosque/","address":{"streetAddress":"11450 Robinson Dr.","addressLocality":"Coon Rapids","addressCountry":"United States"},"telephone":"763-392-0281","sameAs":"nusratmosque@gmail.com"}}]
</script><aside class="widget-4 widget-even widget">			<div class="textwidget"><div style="width:320px;height:50px">
<script type="text/javascript">broadstreet.zone(43522);</script>
</div>
</div>
		</aside><aside class="widget-5 widget-odd widget">			<div class="textwidget"><script type="text/javascript">broadstreet.zone(43518);</script>
</div>
		</aside><aside class="widget-6 widget-even widget">			<div class="textwidget"><script type="text/javascript">broadstreet.zone(43519);</script>
</div>
		</aside><aside class="widget-7 widget-last widget-odd widget">			<div class="textwidget"><script type="text/javascript">broadstreet.zone(43520);</script>
</div>
		</aside>    </div>
            </div>
        </div><!-- #story-content end -->
    </div><!-- #story-page -->

    <footer>
  <div id="footer-sitelogo"><a href="http://abcnewspapers.com">
    <a href='http://abcnewspapers.com/' title='ABC Newspapers' rel='home'>
              <img src='http://abcnewspapers.com/wp-content/uploads/sites/19/2015/07/abcnewspapers.png' alt='Logo'>
          </a>
  </div>
  <nav class="links-menu-wrapper" role="navigation">
	<span class="links-menu-intro"></span> 
	<div class="links-menu"><ul id="menu-links-menu-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-162323"><a href="http://abcnewspapers.com/advertising-information/">Advertising Information</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-162325"><a href="http://abcnewspapers.com/subscribe/">Subscribe</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-162532"><a href="http://abcnewspapers.com/newsstand-locations/">Newsstand Locations</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-171621"><a href="http://abcnewspapers.com/links/">Links</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-162324"><a href="http://abcnewspapers.com/contact-us/">Contact Us</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-180972"><a href="http://theadspider.com">Jobs &#038; Classifieds</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-202272"><a href="http://local.abcnewspapers.com/ads">Weekly Print Ads</a></li>
</ul></div></nav>  <div id="footer-credit">Copyright &copy;2017 <a href="http://ecmpublishers.com" title="ECM Publishers Inc">ECM Publishers, Inc.</a> &#8226; All Rights Reserved</div>
  <div id="scrolltotop">
    <svg  version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" viewBox="0 0 64 64">
      <path d="M32 2l-30 30h18v32h24v-32h18z" ></path>
    </svg>
  </div>
  
<!--
<div id="p2_player_inject_8c251d3a9e5e8a43302e3fffe91078a4"></div>
<SCRIPT SRC="http://dat.localyokelmedia.com/ttj?id=5598630" TYPE="text/javascript"></SCRIPT>
 -->
<iframe src="https://mautic.ecmpublishers.com/media/files/onesignaliframe.html" style="display: none;"></iframe>      <script type='text/javascript' src='http://abcnewspapers.com/wp-content/plugins/awesome-weather-pro/js/awesome-weather-widget-frontend.js?ver=1.1'></script>
<script type='text/javascript' src='http://abcnewspapers.com/wp-content/plugins/awesome-weather-pro/js/js-cookie.js?ver=1.1'></script>
<script type='text/javascript' src='http://abcnewspapers.com/wp-content/plugins/wens-responsive-column-layout-shortcodes/assets/js/custom.js?ver=3.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var JQLBSettings = {"fitToScreen":"0","resizeSpeed":"400","displayDownloadLink":"0","navbarOnTop":"0","loopImages":"","resizeCenter":"","marginSize":"","linkTarget":"","help":"","prevLinkTitle":"previous image","nextLinkTitle":"next image","prevLinkText":"\u00ab Previous","nextLinkText":"Next \u00bb","closeTitle":"close image gallery","image":"Image ","of":" of ","download":"Download","jqlb_overlay_opacity":"80","jqlb_overlay_color":"#000000","jqlb_overlay_close":"1","jqlb_border_width":"10","jqlb_border_color":"#ffffff","jqlb_border_radius":"0","jqlb_image_info_background_transparency":"100","jqlb_image_info_bg_color":"#ffffff","jqlb_image_info_text_color":"#000000","jqlb_image_info_text_fontsize":"10","jqlb_show_text_for_image":"1","jqlb_next_image_title":"next image","jqlb_previous_image_title":"previous image","jqlb_next_button_image":"http:\/\/abcnewspapers.com\/wp-content\/plugins\/wp-lightbox-2\/styles\/images\/next.gif","jqlb_previous_button_image":"http:\/\/abcnewspapers.com\/wp-content\/plugins\/wp-lightbox-2\/styles\/images\/prev.gif","jqlb_maximum_width":"","jqlb_maximum_height":"","jqlb_show_close_button":"1","jqlb_close_image_title":"close image gallery","jqlb_close_image_max_heght":"22","jqlb_image_for_close_lightbox":"http:\/\/abcnewspapers.com\/wp-content\/plugins\/wp-lightbox-2\/styles\/images\/closelabel.gif","jqlb_keyboard_navigation":"1","jqlb_popup_size_fix":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='http://abcnewspapers.com/wp-content/plugins/wp-lightbox-2/wp-lightbox-2.min.js?ver=1.3.4.1'></script>
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/webfont/1.5.18/webfont.js?ver=1.5.18'></script>
<script type='text/javascript' src='http://abcnewspapers.com/wp-content/themes/paperboy/js/slick/slick.min.js?ver=1.0.0'></script>
<script type='text/javascript' src='http://abcnewspapers.com/wp-content/themes/paperboy/js/jquery.inview.min.js?ver=1.1'></script>
<script type='text/javascript' src='http://abcnewspapers.com/wp-content/themes/paperboy/js/paperboy.js?ver=1.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var a3_lazyload_params = {"apply_images":"1","apply_videos":"1"};
var a3_lazyload_params = {"apply_images":"1","apply_videos":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='//abcnewspapers.com/wp-content/plugins/a3-lazy-load/assets/js/jquery.lazyloadxt.min.js?ver=1.7.1'></script>
<script type='text/javascript' src='//abcnewspapers.com/wp-content/plugins/a3-lazy-load/assets/js/jquery.lazyloadxt.srcset.min.js?ver=1.7.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var a3_lazyload_extend_params = {"edgeY":"0"};
var a3_lazyload_extend_params = {"edgeY":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='//abcnewspapers.com/wp-content/plugins/a3-lazy-load/assets/js/jquery.lazyloadxt.extend.js?ver=1.7.1'></script>
<script type='text/javascript' src='http://abcnewspapers.com/wp-includes/js/wp-embed.min.js?ver=78ceedbb703a626b7e40922992d75818'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"platform":"wordpress@4.7.4","language":""},"disqusIdentifier":"202684 http:\/\/abcnewspapers.com\/?p=202684","disqusShortname":"abcnewspapers","disqusTitle":"Blaine seeks high-end grocery store","disqusUrl":"http:\/\/abcnewspapers.com\/2017\/05\/18\/blaine-seeks-high-end-grocery-store\/","options":{"manualSync":false},"postId":"202684"};
/* ]]> */
</script>
<script type='text/javascript' src='http://abcnewspapers.com/wp-content/plugins/disqus-comment-system/media/js/disqus.js?ver=78ceedbb703a626b7e40922992d75818'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"abcnewspapers"};
/* ]]> */
</script>
<script type='text/javascript' src='http://abcnewspapers.com/wp-content/plugins/disqus-comment-system/media/js/count.js?ver=78ceedbb703a626b7e40922992d75818'></script>
</footer>
</div>
<!--END: Canvas -->
</div>
<!--END: Page -->
<script>/* <![CDATA[ */(function(d,s,a,i,j,r,l,m,t){try{l=d.getElementsByTagName('a');t=d.createElement('textarea');for(i=0;l.length-i;i++){try{a=l[i].href;s=a.indexOf('/cdn-cgi/l/email-protection');m=a.length;if(a&&s>-1&&m>28){j=28+s;s='';if(j<m){r='0x'+a.substr(j,2)|0;for(j+=2;j<m&&a.charAt(j)!='X';j+=2)s+='%'+('0'+('0x'+a.substr(j,2)^r).toString(16)).slice(-2);j++;s=decodeURIComponent(s)+a.substr(j,m-j)}t.innerHTML=s.replace(/</g,'&lt;').replace(/\>/g,'&gt;');l[i].href='mailto:'+t.value}}catch(e){}}}catch(e){}})(document);/* ]]> */</script></body>
</html>

<!-- Dynamic page generated in 0.936 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2017-05-18 17:24:17 -->

<!-- super cache -->